Support forumCategory: QuestionsSeveral issues with dates and mobile version (edit: solved with great help by Nikola)
leifballfreunde asked 2 years ago

Hi Nikola,

we have to admit we are very disappointed by your support and also personally.
We bought the extended version, couldn’t use it so far for a single lead in our company because we are having multiple issues. We asked kindly for support in this forum and either you haven’t responded at all or you stopped responding very shortly.

We are aware of you being able to answer other questions but not ours which is kind of frustrating. I would understand if you just have no clue what’s going on but not answering at all to customers who bought your service is unacceptable.

This is my last attempt to receive an answer before I am forced to rate your tool possibly not in the best way.

Here are the links to our problems again:
https://easy-appointments.net/support/bug-span-classea-required-span-in-required-field-announcement/
https://easy-appointments.net/support/problems-with-date-and/
https://easy-appointments.net/support/invalid-date-on-mobile-devices/#answer-18000

Hoping for your humanity!
Kind regards
Leif

4 Answers
Nikola Loncar Staff answered 2 years ago

Hi Leif, sorry for waiting 🙁 there are so many things going on in parallel so it’s hard to keep up. Regarding span thing it is removed because there is no way of having translation with html elements. It was done in latest version.

Regarding issue with mobile version I will look that during the day and let you know.

Best regards,
Nikola

leifballfreunde replied 2 years ago

Hey Nikola,
thanks for coming back to me. I appreciate it a lot!
I do understand it’s hard to follow up – but if you would people just let know about it then they know you are still trying to help. Otherwise they think you ignore them.

I have to admit I haven’t seen the new version. It actually fixed the problem of not being able to fill out the form when you change the language of our website.

The span issue remains on our default german website. It’s gone on every other language. Could you maybe explain it a bit more how ti fix it?

Other than that it remains the problem with the invalid date on the mobile version. Thanks for having a look into it today!

Best regards
Leif

Nikola Loncar Staff answered 2 years ago

Hi Leif, I have tried on mobile phone and issues where related to auto translate function from mobile phone. So those translations make calendar not working right. Can you please disabling it and try again?

Best regards,
Nikola

leifballfreunde replied 2 years ago

Hi Nikola,
I have disabled it and the “span” issue is indeed gone, but the “invalid date” issue on mobile remains.

leifballfreunde replied 2 years ago

I have just check it with another phone (Samsung S8 with Chrome). Here it works fine.
It’s not working with my iphone 6s (Safari)

leifballfreunde replied 2 years ago

Same on my Iphone 6s in Chrome

leifballfreunde replied 2 years ago

Same bug on an Iphone 11 in Chrome ans Safari

Nikola Loncar Staff replied 2 years ago

Thanks that will help, I have iPhone 11 to test it.

Best regards,
Nikola

Nikola Loncar Staff replied 2 years ago

I will need one more info. What is date time format settings from your WP Settings > General page?

Best regards,
Nikola

leifballfreunde replied 2 years ago

Interesting approach.
It’s:
j. F Y
Ending in something like 22. Oktober 2020

Nikola Loncar Staff replied 2 years ago

Hi, can you please try with latest version 3.0.11?

Best regards,
Nikola

leifballfreunde replied 2 years ago

Hi Nikola,
since the update I can not see the form on mobile at all.
I haven’t changed anything – the shortcode is still the same as on friday and it’s showing the form on a desktop application. Cache is deleted…

Nikola Loncar Staff replied 2 years ago

Hi, it’s there but styles on your page are hiding it. You have this part in element above EA that is hiding content:

display: none !important;

Can you please try creating new content row and place EA shortcode in it.

Best regards,
Nikola

leifballfreunde replied 2 years ago

Good morning Nikola,
weird, but you were correct.
Anyway, the invalid date is still appearing. Is it gone on your Iphone?

Best regards
Leif

Nikola Loncar Staff replied 2 years ago

Hi, Leif can you please try one thing. Can you change date/time format inside your admin panel? Set format that is with numbers only.

Best regards,
Nikola

leifballfreunde replied 2 years ago

Hi Nikola,

apparently it just helped to change the date/time and change it back to what we had and voilà it works. Thanks a lot! If you could just help me out with the issue that the date and some strings can’t be seen on mobile, even if I zoom out. (pls see picture attached)
I have tried to set the width to auto, but it didn’t work.

https://www.directupload.net/file/d/5984/si5a7bmv_png.htm%5D%5BIMG%5Dhttps://s12.directupload.net/images/201027/temp/si5a7bmv.png

Thanks again! I appreciate

leifballfreunde answered 2 years ago
leifballfreunde replied 2 years ago

Sorry, for double posting. Was not my intention and can’t find the delete button.

Would also like to edit the thread title in order to show my appreciation for your help! Is it possible?

Nikola Loncar Staff replied 2 years ago

I can edit it. Just tell me what do you want to have there. Also regarding that string issue I will send you custom CSS that you can apply so it will break that long line.

Best regards,
Nikola

leifballfreunde replied 2 years ago

Custom CSS would be fantastic. Could you pls also name me the class of the disabled timeslots? I’d like to change the background color from beige to red.
Last question: I have tried to translate some custom fields exactly how your video has shown (With PO/MO files). Unfortunately it’s not working. Has something changed since the last update that makes this not possible anymore?

Pls name it into “Several issues with dates and mobile version (edit: solved with great help by Nikola)”

leifballfreunde replied 2 years ago

Solved the translation problem, so pls do not worry about it.

Nikola Loncar Staff answered 2 years ago

Hi, custom CSS is :

.ea-bootstrap {
white-space: inherit !important;
}

add this to EA Settings > Customize > Custom styles. Also purge cache if there are some.

Best regards,
Nikola