Support forumCategory: Questionsunexpected-t_function
Angel Goranchev asked 4 years ago

Hi, i have a problem by installing easy-appointments, the following error appears: \\\”Extension can not be included because it causes a fatal error: Parse error: syntax error, unexpected T_FUNCTION in home/…/wp-content/plugins/easy-appointments/main.php on line 126\\\” Thank you

2 Answers
Nikola Loncar Staff answered 4 years ago

Looks like issue with PHP version on your site. Can you please tell me which PHP version do you have on your hosting?

Best regards,
Nikola

tomasz_rejman replied 4 years ago

Hi, can you please help with that issue? My php version is PHP Version 5.2.17.

Nikola Loncar Staff replied 4 years ago

H, that is really old version of PHP can please update to newer version. To get everything working fine you should have at least 5.3. Actual version of PHP now is >7

tomasz_rejman replied 4 years ago

Thanks a lot!!! Yes, this was the problem.

tomasz_rejman answered 4 years ago

Hi, I’ve got the same problem: “Parse error: syntax error, unexpected T_FUNCTION in /wp-content/plugins/easy-appointments/main.php on line 126”. Which PHP version is good for the plugin? I can’t find that info on your site. Thanks in advance.