Support forumCategory: BugsUncaught ReferenceError: ea_settings is not defined
robert_frost asked 9 months ago

I have the same problem as another user but there is no solution beneath their question.
The page is: https://puconsport.cl/easy-appointments/
Full Error:
Uncaught ReferenceError: ea_settings is not defined
at Plugin.init (frontend-bootstrap.js?ver=3.7.3:74:13)
at new Plugin (frontend-bootstrap.js?ver=3.7.3:22:14)
at HTMLDivElement.<anonymous> (frontend-bootstrap.js?ver=3.7.3:1215:59)
at Function.each (jquery.min.js?ver=3.6.0:2:3003)
at s.fn.init.each (jquery.min.js?ver=3.6.0:2:1481)
at s.fn.init.jQuery.fn.<computed> [as eaBootstrap] (frontend-bootstrap.js?ver=3.7.3:1213:14)
at frontend-bootstrap.js?ver=3.7.3:1225:29
at frontend-bootstrap.js?ver=3.7.3:1226:3
I also had this error on activation of the extension plugin:
The plugin generated 3140 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.
 

robert_frost replied 9 months ago

There is also this error in the console:

DevTools failed to load source map: Could not load content for https://puconsport.cl/wp-content/plugins/easy-appointments/components/bootstrap/ea-css/bootstrap.css.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

I have wp_debug enabled but there are no php errors displaying on the page.

Nikola Loncar Staff replied 9 months ago

Hi that css.map file should not be an issue.

4 Answers
Nikola Loncar Staff answered 9 months ago

Hi, can you please try clearing Cache if you are having it on your site. That value is embedded inside page (ea_settings).

Best regards,
Nikola

robert_frost replied 9 months ago

I have just purged the cache and still no luck – I had exactly the same problem on the live and local install.

robert_frost replied 9 months ago

I have made a location, service, employee and a connection.
If there is something else that needs doing before it works then you need to tell me.

robert_frost answered 9 months ago

I paid for this plugin 2 days ago and still it does not work and I have had only one reply in that time.

Nikola Loncar Staff replied 9 months ago

What theme was used on that site?

robert_frost replied 9 months ago

Twenty Twenty Two

Nikola Loncar Staff answered 9 months ago

Hi Robert, can you please create a wp admin account so I can log in and see what is going on there?

Best regards,
Nikola

robert_frost replied 9 months ago

Hey I have just created an account but where can I send the details, not too keen on just posting the password in public

Apologies for the late response.

Nikola Loncar Staff answered 9 months ago

Hi Robert, we have located the issue and it will be fixed within 24h. There will be new release within that time period. If you don’t want to wait and test it in the meanwhile just use regular theme instead of those 2022.

Best regards,
Nikola

robert_frost replied 9 months ago

Thanks Nikola, if you need any more info just ask.