Support forumCategory: QuestionsSettings Validation Problem
Kirsty asked 4 years ago

Hi,
I have installed the plugin, set up a location, service and worker, created a connection and some timeslots, then embedded the Easy Appointments in a page using the 

shortcake.
When I publish the page, I get the following message:

East Appointments – Settings validation:
You need to define at least one location.
You need to define at least one service.
You need to define at least one worker.
There should be at least one Connection.

Is there something obvious I am missing?
I have used this plugin before on a different website and it worked perfectly, so confused what is going wrong here when I have set all the things it is asking for in the error message.
Any help gratefully received!

3 Answers
Nikola Loncar Staff answered 4 years ago

Hi Kirsty,

can you tell me do you use latest version of plugin? Can you pease provide me a link to that page?

Best regards,
Nikola

Nikola Loncar Staff replied 4 years ago

Latest version is 2.2.4

kpitkin replied 4 years ago

Hi Nikola,

I am using 2.2.4 (I installed it directly from the WordPress plugin directory today).

The page I am using for the shortcode is http://girlguidingbath.org.uk/hq-booking/

I have just tried using the [ ea standard ] shortcode rather than the bootstrap, but no difference either way.

Many thanks!

Nikola Loncar Staff answered 4 years ago

Hi, can you please take a screen shot of that connection inside Settings > Connections page?

Best regards,
Nikola

kpitkin replied 4 years ago

Hi Nikola,

I can, but I don’t seem to be able to attach it to my comment here. I have put the image on Dropbox at https://www.dropbox.com/s/mab3wub6bz89jlu/Easy%20Appointments%20Connections%20Screenshot.png?dl=0

Nikola Loncar Staff answered 4 years ago

Hi, I have just check that screen shot please set Connections from Not working to Working (column “Is Working”) 🙂
Best regards,
Nikola

kpitkin replied 4 years ago

Ah ha! Wonderful – thank you!