Support forumCategory: QuestionsCustom field data missing in email
webpixelmedia asked 2 years ago

Everything is working great for me except for this one issue.
I need to pass user data (some custom fields attached to the user, plus user ID) to the admin notification email, without displaying it to the user.
So I uncheck “Visible” for the form field, and now the data is missing from the email.
Is there something else I need to do, or set to get it to work?
Thanks.
 

8 Answers
Nikola Loncar Staff answered 2 years ago

I am not sure that I understand you have that value but field is not marked as visible and it can’t be part of email value?

Best regards,
Nikola

webpixelmedia replied 2 years ago

Hi, is there any update on this?

webpixelmedia answered 2 years ago

Hi Nikola, thanks for the reply.
When a field is not Visible, it stops working, and the data is not being passed correctly to the form.
In my case, the site is for language teachers. The student books a teacher. Certain private data about the student (i.e. the User) must be passed to the teacher, including the student ID, and custom fields including how many credits they have left on their account, previous lesson history etc. so that the teacher (worker) has the relevant information they need to know for the booking and for making their report after the lesson. The student must not have access to edit that data (like their own user ID), so the fields must be “not visible”. So, I uncheck the “Visibility” setting.
The problem now is that the fields are failing to pass their data, and the information in the email shortcodes like #user-id# and other custom fields attached to the user account are lost, and the worker receives an email which is missing the most important data for the booking.
Is there something I’m not doing correctly that is causing the hidden fields to lose their values in the email?
Thanks.
 

Nikola Loncar Staff answered 2 years ago

Hi, this will be fixed. That value will be visible inside email template.

Best regards,
Nikola

webpixelmedia replied 2 years ago

Hi Nikola, do you have a timescale for this?
We’re waiting to launch for months, and we can’t do so until this is working properly.

webpixelmedia replied 2 years ago

Any update?

webpixelmedia answered 2 years ago

That\’s great, thank you! It’s the last task I have to complete before my client can launch their site.

Nikola Loncar Staff answered 2 years ago

Hi, today we are planning to add option that will render those fields as hidden input fields. So you can put some value there if you want via some custom javascript code and that will be saved inside Appointments data. Will that solve the issue that you have?

Best regards,
Nikola

Nikola Loncar Staff answered 2 years ago

Hi can you please update to latest version and try. Inside EA Settings > Custom form fields there should be dropdown instead of simple visible checkbox. 🙂

Best regards,
Nikola

webpixelmedia answered 2 years ago

Hi Nikola,
many thanks for this, it works perfectly!
Apologies for the delay in replying.

Nikola Loncar Staff answered 2 years ago

Thanks for update, I will close this thread.

Best regards,
Nikola