Support forumCategory: QuestionsCnflict with Php version 5.4
M. asked 5 years ago

Hi, Nikola,
 

Earlier today, I posted a request for help (under the category of Bugs) after your current update caused the plugin to deactivate. I was especially concerned because the plugin broke the site when we launched it owing to a conflict with Php version 5.4 and I didn’t want to risk that again.
 
After a thorough investigation we discovered the problem was owing to a specific conflict with Php version 5.4. Upgrading to 5.6 seemed to fix it but it does put into question your claim that the plugin will run on any version beyond 5.3.
 
These are the notes the developer I work with shared with me:
The EasyAppointments plugin when it initializes, compares the version of php to see if it is less than 5.3. If it is NOT less than 5.3, then they use a different class loader. For php > 5.3 they rely on “composer” to construct the class loader, with require_once dirname(__FILE__) . ‘/vendor/autoload.php’. This is a little puzzling to me, because it seems it ought to use composer for either 5.4 or 5.6.
 
 
The source for EasyAppointments is at github, and the composer.json file there says require php>=5.6 so the EasyAppointments developer is saying his code won’t work on 5.6. I think the item above is irrelevant – I don’t think his code matters. I think it is simply that Easy Appointments won’t work on php 5.4. 
 
Perhaps this information will inspire you to investigate. At the very least, it might serve someone who runs into the same problem.
 
Thanks again for your wonderful plugin.
 
Best,

M.

1 Answers
Nikola Loncar Staff answered 5 years ago

Hi,

thanks for the info, can you please check the error log file on the server? If there where some errors it should be recorded there. Also I have removed previous topics because they are similar. If you want to continue conversation within this thread please register.

Best regards,
Nikola