Support forum2-5-7-not-available
haelsite asked 1 month ago

In this web https://es.wordpress.org/plugins/easy-appointments/advanced/ exist last versión 2.5.7 but only 2.5.6 Is avsilable.