Support forumCategory: BugsPlugin is producing the error
Alex asked 2 weeks ago

Hi,
After last plugin update plugin is producing an error

Warning: class_exists() expects parameter 1 to be string, array given in /home/atgrace1/public_html/wp-content/plugins/easy-appointments/vendor/lucatume/di52/src/tad/DI52/Container.php on line 231

Warning: class_exists() expects parameter 1 to be string, array given in /home/atgrace1/public_html/wp-content/plugins/easy-appointments/vendor/lucatume/di52/src/tad/DI52/Container.php on line 231
 

3 Answers
Nikola Loncar Staff answered 2 weeks ago

Hi Alex, can you please tell me what was previous version before update?

Best regards,
Nikola

alexandra_lepikhin replied 2 weeks ago

Hi Nikola,

I am updating regularly, but never thought of recording version before an update – just updating all plugins wherever I can see that updates are available.
My current versions are:
Easy Appointment Version 2.11.1
Easy Appointments Connect Version 0.11.5

Thanks,

Alex.

alexandra_lepikhin answered 2 weeks ago

Hi Nikola,
 
I am updating regularly, but never thought of recording version before an update – just updating all plugins wherever I can see that updates are available. 
My current versions are:
Easy Appointment Version 2.11.1
Easy Appointments Connect Version 0.11.5
 
Thanks,
 
Alex.
 

Nikola Loncar Staff replied 2 weeks ago

Hi Alex, thanks for that. Can you please just check the PHP version that you have on your hosting so I can check locally? 🙂

Best regards,
Nikola

alexandra_lepikhin replied 2 weeks ago

Hi Nikola, below the data from Hosting cPanel:
cpsrvd 11.66.0.24
Database client version: libmysql – 5.1.73
PHP extension: mysqliDocumentation curlDocumentation mbstringDocumentation
PHP version: 5.6.30

Thanks,

Alex

Nikola Loncar Staff answered 2 weeks ago

Hi Alex can you please try with latest version 2.12.0?

Best regards,
Nikola

alexandra_lepikhin replied 2 weeks ago

Hi Nikola,
Thanks. Problem solved. Really appreciate your prompt action.
Thanks,

Alex